Frequesntly Asked Questions About JailbreakMe 3.0

Earlier today Comex released his popular and one of the easiest method of jailbeaking, JailbreakMe 3.0, which supports all idevices i.e., iPhone 4 (both GSM and CDMA versions), iPad 1 and 2, iPhone 3GS, iPod Touch 3G and iPod Touch 4G running on iOS 4.3.3. The main purpose of this new jailbreak is to jailbreak iPad 2 which was un-jailbreakable till this morning.

In this post we have compiled a list of frequently asked questions and their answers for those users who are new to jailbreaking and for those who are confused which one to apply on which idevice.

Q: How many jailbreak tools are available?

Ans: There are many jailbreak tools available like Redsn0w, Greenpoison, PwnageTool, Sn0wbreeze, Blackra1n, Purplera1n, Spirit depending on the iOS version.

Q: What is the difference between jailbreakme and other jailbreak tools?

Ans: JailbreakMe is userland tool which doesn’t require anything except internet question. Moreover, jailbreakme 3.0 is based on Unionf instead of traditional stashing approach.

Q: Which models and iOS versions are supported?

Ans: The following devices and iOS version can be jailbroken with JailbreakMe 3.0:

  • iPad1: 4.3 through 4.3.3
  • iPad2: 4.3.3
  • iPhone3GS: 4.3 through 4.3.3
  • iPhone4: 4.3 through 4.3.3
  • iPhone4-CDMA: 4.2.6 through 4.2.8
  • iPod touch 3g: 4.3, 4.3.2, 4.3.3
  • iPod touch 4g: 4.3 through 4.3.3

Q: What if my device is already jailbroken with another jailbreak tool?

Ans: If your device is already jailbroken with another device, you don’t need to rejailbreak it. If you re-jailbreak your device, Cydia will forget all the packages and the apps installed through Cydia won’t work any more. You will have to reinstall every thing.

Q: Can I downgrade to previous version once the device is jailbroken?

Ans: You can downgrade to any previous version provided you have SHSH blobs saved with Cydia for the iOS you are downgrading to. However, downgrading won’t be possible with iPad 2 3G models once Apple stops signing iOS 4.3.3. iPad 2 WiFi models can/will be dowgraded to previous iOS version. iPad 2 uses A5 chip for which there is no bootrom level exploit available yet.

Q: Should I save the SHSH blobs?

Ans: Yes, you should save the SHSH blobs, both locally and on cydia servers, as soon as possible so that you can downgrade to iOS 4.3.3 once Apple releases iOS 4.3.4 or iOS 5. For this purpose you can either use iSHSHit app from Cydia or TinyUmbrella.

Q: Is there any risk if I jailbreak my device with JailbreakMe?

Ans: As long as you don’t download the PDF files from any un-trusted sources, there is no risk involved in jailbreaking your device with JailbreakMe. However, you should install PDF Patcher 2 from Cydia after jailbreaking to avoid any type of risk.

Q: I heard this new unionfs stuff is dangerous?

Ans: Define dangerous :)  Seriously though, although unionfs is a huge improvement to the install time of the jailbreak, it is brand new code and there is the possibility something will go wrong.  Just keep regular backups of your media and content and you should be fine.  If there are any problems, they should appear within the first few days, so hold off and let “everyone else” test the waters if you’d like.

If you still have any doubts or question, please feel free to ask through our commenting system. Alternatively, you can follow us on Twitter or join our Facebook fanpage to keep yourself updated.

Leave a Reply

Your email address will not be published. Required fields are marked *