PDF Patch by Saurik to Fix PDF Exploit for all iDevices and iOS versions

PDF Patch fixes the PDF holes in all iOSs from 2.x to 4.x for iPhone and iPod. Yesterday Apple rolled out iOs 4.0.2 for iPhone and iPod to fix this vulnerability, but iPhone 2G and iPod Touch 1G user are still at risk because iOS 4.x doesn’t support these devices.

PDF Patch for iPhone 2G and iPod Touch 1G

On Wednesday, Apple (finally) released firmware 4.0.2, which patches the very large security holes exploited by @comex in the 2nd incarnation of jailbreakme.com. The only problem is they outright abandoned iPhone2G and iPod Touch 1G users! Even though Apple acknowledges in their security update the severity of these holes, they left iPhone2G and ipt1G owners high and dry — completely vulnerable to truly malicious variants of jailbreakme (these variants aren’t out yet, but they’re sure to come!).Luckily for Apple, the Jailbreak community isn’t so callous. @saurik has been burning the midnight oil coding a Cydia package (PDF Patch) that will fix the holes for all devices and all firmware versions (even going back to version 2.x!).

Though we have already shared an app for jailbroken devices that warns you before a PDF file starts to download, but again the app “PDF Loading Warner” doesn’t protect the older iOS versions.

Saurik, the founder of Cydia Store, released a new app “PDF Patch” for jailbroken devices on all iOS versions. First of all jailbreak your device with JailbreakMe and then install PDF Patch from Cydia to make your phone safe and sound.

Want automatic updates? Subscribe to our RSS feed or
Get Email Updates sent directly to your inbox!

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.