Snowbreeze 2.0 to Support Firmwares 3.0.x to iOS 4.0.1

snowbreeze v2.0 download

Snowbreeze v2.0 is coming soon to support all the firmwares from 3.0.x to iOS 4.0.1. However this version does not have any new exploits for iPhone 3GS new bootrom. It is to remind you that to jailbreak iOS 4.0.1 your iPhone should be pre-jailbroken on iOS 4.1.

sn0wbreeze 2.0

The guides to jailbreak iPhone 3GS, iPhone 3G, iPod Touch 2G and iPod Touch 3G have already been shared with you. If you have missed any our guide, here are links:

We will share the complete tutorial and download link for Sn0wbreeze version 2.o as soon asĀ  it is released. Say tuned for new info.

[via twitter]

Want automatic updates? Subscribe to our RSS feed or
Get Email Updates sent directly to your inbox!

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.